Help - Search - Members - Calendar
Full Version: Yet another alternator question
914World.com > The 914 Forums > 914World Garage
ThePaintedMan
Sorry for asking one that I'm sure has been answered before. Searched but couldn't find a thread that sounded quite like my issue. Getting ready for a track day next week, and of course having charging issues. Typically I see the alt light come on with ignition on, but it shuts off as soon as I start the car. Occasionally it does come on when I turn the ignition on, but the next time it doesn't. Now, it doesn't come on when the ignition is on or when it's running. I suspect it isn't charging regardless because I see 12.2 volts with the car off and about the same while it's running. The car has been sitting but it was charging prior to this and it was covered with one of Perry's excellent covers. I wonder if the brushes are bad, but I think it sounds more like a bad relay board.
The Cabinetmaker
Alternators don't have brushes. Check the bulb for the light. It's part of the charging system. Won't charge without it.
dr914@autoatlanta.com
relay boards do not go bad that often, and have not had one affect the charging system, I would substitute the voltage regulator second after making sure the belt is tight. Also make sure that the battery neg cable is cleanly attached to the right firewall and battery terminal. 914 alternators do not fail that often. Even if the bulb on the dash is bad it will not prevent the alternator from charging.


QUOTE(ThePaintedMan @ Jul 11 2018, 07:36 AM) *

Sorry for asking one that I'm sure has been answered before. Searched but couldn't find a thread that sounded quite like my issue. Getting ready for a track day next week, and of course having charging issues. Typically I see the alt light come on with ignition on, but it shuts off as soon as I start the car. Occasionally it does come on when I turn the ignition on, but the next time it doesn't. Now, it doesn't come on when the ignition is on or when it's running. I suspect it isn't charging regardless because I see 12.2 volts with the car off and about the same while it's running. The car has been sitting but it was charging prior to this and it was covered with one of Perry's excellent covers. I wonder if the brushes are bad, but I think it sounds more like a bad relay board.

Edward Blume
I had my alternator fully rebuilt and it turned out to be the wiring. Have you done anything to the wiring lately?
worn
QUOTE(dr914@autoatlanta.com @ Jul 11 2018, 12:33 PM) *

relay boards do not go bad that often, and have not had one affect the charging system, I would substitute the voltage regulator second after making sure the belt is tight. Also make sure that the battery neg cable is cleanly attached to the right firewall and battery terminal. 914 alternators do not fail that often. Even if the bulb on the dash is bad it will not prevent the alternator from charging.


QUOTE(ThePaintedMan @ Jul 11 2018, 07:36 AM) *

Sorry for asking one that I'm sure has been answered before. Searched but couldn't find a thread that sounded quite like my issue. Getting ready for a track day next week, and of course having charging issues. Typically I see the alt light come on with ignition on, but it shuts off as soon as I start the car. Occasionally it does come on when I turn the ignition on, but the next time it doesn't. Now, it doesn't come on when the ignition is on or when it's running. I suspect it isn't charging regardless because I see 12.2 volts with the car off and about the same while it's running. The car has been sitting but it was charging prior to this and it was covered with one of Perry's excellent covers. I wonder if the brushes are bad, but I think it sounds more like a bad relay board.


Never seen you wrong before about 914 function, but if the bulb burns out the alternator has no power to start the windings. Won’t charge. Has to allow at least two watts. The Pelican site for 911s has an excellent diagnostic page.
worn
QUOTE(The Cabinetmaker @ Jul 11 2018, 08:37 AM) *

Alternators don't have brushes. Check the bulb for the light. It's part of the charging system. Won't charge without it.

They do have brushes. That doesn’t mean they are bad though.
Dave_Darling
If the regulator is unplugged, I know the alternator light won't come on--and the battery won't charge So it stands to reason that a problem in the regulator or the relay board might also cause that....

--DD
porschetub
QUOTE(worn @ Jul 12 2018, 12:18 PM) *

QUOTE(The Cabinetmaker @ Jul 11 2018, 08:37 AM) *

Alternators don't have brushes. Check the bulb for the light. It's part of the charging system. Won't charge without it.

They do have brushes. That doesn’t mean they are bad though.

agree.gif strange reply,yep the light might be working but that has no indication the battery is getting any more juice under load...ask me how I know,mine go's off and has no issue with engine running except appears to be reading no more that battery power under load/rpm....PITA to remove in a six after I had it rebuilt,why???.
Spoke
Below is the schematic of the alternator/battery/Voltage Regulator circuit in the 914.

Your GEN light doesn't light now. Trace the path to light the GEN light from the Battery when you turn on the key and engine off:

Battery through Fuse F9 to one side of the GEN light.
Other side of the GEN light to the D+ connector at the VR.
From D+, path is through the relay in the VR to DF at the alternator.
From DF in the alternator through the armature (rotating part) and its brushes to ground.

To test the GEN light and alternator, remove the VR and short D+ to DF at the VR pins on the relay board. This will cause the alternator to produce maximum voltage when the engine is running.

With the engine OFF, when you turn the key ON with D+ <> DF connected, the GEN light should light.

This will test all the wiring, the relay board, the armature and its brushes.

If the GEN light is off during this test, several items may be suspect:
GEN light bulb is bad; test separately out of the socket.
Visually inspect the GEN light socket and connections to make sure they are clean and secure.
Fuse F9 is bad or dirty contacts. Check F9 with an ohm meter and clean the contacts.
Wiring/relay board is suspect. Once F9 and GEN light are tested ok, with D+/DF shorted at the VR contacts, remove the connector to the alternator and short DF to ground. The GEN light should come on if the wiring and relay board are ok. If the light doesn't come on, there is an issue with the wiring or relay board.

With this setup, if GEN light is on with engine off, start the car and measure the battery voltage. It should be more than 15V. Do this test quickly as this test applies maximum stress on the alternator and the battery.

If you get more than 15V with the engine running and D+ connected to DF, then chances are your alternator is ok and your VR is suspect.

If you don't get 15V, your alternator may be suspect.


Click to view attachment
ThePaintedMan
Thanks guys! Man, when Spoke starts commenting, I know things are serious, electrically-speaking.

Actually, was able to isolate it down to the wiring at the gauges last night. Bulb is lighting intermittently when the ignition is on if I wiggle stuff. Now just have to brave the heat this evening and clean all the connections. I suspect a bad ground, or in this case, power since they are daisy-chained from one gauge to another.
Elliot Cannon
Wow! What an informative thread. So far I have learned that an alternator may or may not have brushes. I have also learned that the battery may or may not accept a charge if the alternator light on the dash is not good. av-943.gif lol-2.gif laugh.gif biggrin.gif
ThePaintedMan
After cleaning every bulb and connection in the gauges, still kept getting a very strange flicker of the alternator light when the car was just sitting there with the ignition on. I recalled about 4-5 years ago when I had a situation where the alternator wasn't charging and the light was OFF. Back then it was the voltage regulator and sure enough, it was this time as well. All fixed!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.