Help - Search - Members - Calendar
Full Version: No Lights !
914World.com > The 914 Forums > 914World Garage
63acornwall
When I operate the light switch on dash nothing happens - no panel lights , no side lights , no headlamps popping up . All worked ok before and will go have a look with a multimeter tomorrow . Suspect switch as there are 6 or so independent fuses protecting individual items and doubt they have all failed at same time .
Hazard lights work off their switch , turn indicators work off their stalk , reversing lights ( backup lights ) work when reversing .
What shall I try ?
lierofox
QUOTE(63acornwall @ Sep 10 2019, 09:56 AM) *

When I operate the light switch on dash nothing happens - no panel lights , no side lights , no headlamps popping up . All worked ok before and will go have a look with a multimeter tomorrow . Suspect switch as there are 6 or so independent fuses protecting individual items and doubt they have all failed at same time .
Hazard lights work off their switch , turn indicators work off their stalk , reversing lights ( backup lights ) work when reversing .
What shall I try ?


From what you've described I'd start by checking for +12v battery voltage at Terminal #30 on the headlight switch, which should be fed from the back-side (un-fused side) of fuse #10. Make sure neither of those are loose or popped out.

Might also check Terminal 15 which should have +12v when the key is on.
63acornwall
Thanks for that lierofox , will save a lot of time !
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.