Help - Search - Members - Calendar
Full Version: Start not disengagin
914World.com > The 914 Forums > 914World Garage
TX914
Starter (rebuilt SR17X) was not disengaging and getting worse. Took in to Texas Alternator Service as I didn't want another rebuilt unit. They said said it was a dinosaur with a reclaimed solenoid. They happened to have a stock of new solenoids (purchased from Zimms when they closed) and replaced it - $63. Haven't tried it yet as engine is out but wanted to pass this tidbit along for anyone with similar problem. I understand from other threads the problem could also have been ignition switch or relay.

HTH, Alan B
76-914
QUOTE(TX914 @ Oct 17 2020, 05:34 AM) *

Starter (rebuilt SR17X) was not disengaging and getting worse. Took in to Texas Alternator Service as I didn't want another rebuilt unit. They said said it was a dinosaur with a reclaimed solenoid. They happened to have a stock of new solenoids (purchased from Zimms when they closed) and replaced it - $63. Haven't tried it yet as engine is out but wanted to pass this tidbit along for anyone with similar problem. I understand from other threads the problem could also have been ignition switch or relay.

HTH, Alan B

In Austin? They used to be a good outfit, IIRC. Many years back I had a Datsun alt rebuilt there. The belt was always slipping so I went back to see what it might be. The owner took one look at it and said "This was on a Datsun?" I said yes and he hit the roof. The pulley they put on it was the wrong one. He went in the back a chewed everyones ass out. I could hear him from the front yelling. av-943.gif He handed me another alt even thought it had been 1 1/2 years since I bought it and said no charge. beerchug.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2020 Invision Power Services, Inc.